Why does v33 and onward require Lollipop or later?

  1. Home
  2. Knowledge Base
  3. General
  4. Why does v33 and onward require Lollipop or later?

Why does v33 and onward require Lollipop or later?

A few reasons:

  1. An ever-decreasing percentage of Action Launcher’s users are running Android 4.x, and it was increasingly taking a lot of development time to maintain support for Android 4.x.
  2. By requiring Lollipop or later, we can fully embrace newer parts of the Android system we previously didn’t use.
  3. The vast majority of features that arrived since Action Launcher v25 actually required Lollipop or later to use, so Android 4.x users were already not receiving those features.
  4. Even thought updates from v33 onwards require Lollipop or later, Action Launcher v32 will continue to work for Android 4.x users in perpetuity, so we’re not stopping the app from working for anyone.
  5. There’s never a great time to require newer versions of Android, but in 2018, we felt it was acceptable to focus on 2014’s Android release (Lollipop) and later.

By focusing on Lollipop and later, we can develop more modern, cooler features, faster than we were doing so when maintaining Android 4.x support. We hope you understand 😀.

 

Related Articles